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7.06.01 Infrastructure Sector Tutorial        

Disclaimer: The objective of this tutorial is to get familiar with the GIS  
software. The tutorial only covers some parts that are being done in a  
real analysis. The results that are being displayed in the tutorial can’t be  
compared with the results a real analysis would generate.

Introduction
The objectives of this exercise are to get more familiar to some basic 
ArcGIS operations. We will create shapefiles, work with attribute data 
in Excel, digitize features to a new shapefile and join attributes to a 
shapefile.

The scenario of this exercise is that we will prepare an analysis based  
on road data to identify the bottlenecks of a road leading from the  
transport  corridor  at  the  municipal  boundary  where  a  major  new 
settlement is located to the poblacion at the lake. 

It should be noted that the procedure (digitizing an already digitized  
feature)  in  the  tutorial  is  very  unlikely  to  be  used  in  real  GIS 
applications. Rather, the existing road layer would be broken down in 
segments constituting a network, and the attribute data would be joined 
to the original, but modified, dataset. Constructing networks in ArcGIS 
is however an advanced task and a precondition is that the software is  
expanded to include network extension applications.

1 Getting started 
1.1 Open ArcMap. Select A new empty map.
1.2 Add the following layers to the workspace: 
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Bdrbgy_pgon
MunRdUTM
ProvRdUTM
The first file is found in C:\HLURB\CLUP\01_CLUPGIS (Laurel)\00_BM\ and the 
two other files are all found in the \02_IS\ folder.

1.3 Assign proper symbology to the layers and rename them in the list of content. 
Since we will digitize the road layers, assign a line symbol with a rather large 
width (e.g. 3,0). See image below. To start changing the symbology, either 
double-click on the layer symbol in the table of content or open the Layer 
Properties window and select the Symbology tab.

1.4. In the menu bar click File > Save As… to save a map document as 
road_analysis_v1 in C:\HLURB\CLUP\01_CLUPGIS (Laurel)\06_Workfolder\.  
Don’t forget to save your progress now and then throughout the exercise.

2 Creating a shapefile
2.1 Open ArcCatalog (click on  in the ArcMap tool bar).
2.2 In the catalog tree, navigate to the C:\HLURB\CLUP\01_CLUPGIS (Laurel)\02_IS\ 

folder. In the menu bar click File > New > Shapefile… The Create New Shapefile 
window appears.

2.3 Type the Name ‘RdAnalysis’ and select Polyline as Feature Type. See image 
below.
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2.4 Assign the same coordinate system as the RdMun layer. First click Edit… to open 
the Spatial Reference Properties window. Click Import, browse for the RdMun 
layer and click OK. See image below.
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2.5 Click OK in the Spatial Reference Properties window. Click OK in the Create New 
Shapefile window. The new shapefile is created.

3 Digitizing
We will use GIS to show road segments that are in a critical or poor  
condition or have an inadequate width compare to road classification 
standards. The road will be digitized in segments where the nodes are  
defined at barangay crossings (so that the analysis can be used for  
comparisons  between  the  barangays)  and  intersections  with  other  
roads (so network analyses can be made). In step 1.2 we added those 
files with road features and barangay boundaries to the workspace and  
we can thus proceed.

A good idea is that you print a map and use the paper map to make a  
sketch where the nodes should be located before you start with the  
screen digitizing:

3.1 Go back to the ArcMap window. (If you have closed it, you can start it again by 

clicking on  in the ArcCatalog toolbar. If this is the case you also have to open 
the map document road_analysis_v1.mxd.)

3.2 Now it is time to add the shapefile we prepared for the analysis of the road 

condition. Click on  and browse for RdAnalysis.shp. Click Add.
Nothing is seen on the map although the RdAnalysis layer is activated  
to be shown. The reason for this of course that no roads have yet been 
digitized into the layer. If you open the attribute table to the shapefile,  
you will find it empty, compare to image below. Now it’s time to start  
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digitizing.

3.3 If it’s not already visible, you need to open the Editor toolbar. In the menu bar click 
Tools > Editor. The Editor toolbar appears. Drag and drop it to a suitable place in 
the workspace (e.g. within the toolbar).

3.4 In the Editor toolbar, click Editor > Start editing. See image below.

3.5 Make sure that the settings are set to Create New Features and that the target 
layer is RdAnalysis. Click ???

3.6 Set the snapping properties so that your digitizing effort will snap to vertices, 
along the line and the endpoints of both the IS01_RdTp2008 and barangay 
layers. In the editor menu, click Editor > Snapping… The Snapping xxx appears 
between the table of content and your map (see image below). Select (check the 
corresponding box) according to what is mentioned above. You can now close the 
Snapping xxx.

The  plan  is  now to  digitize  as  indicated  below.  A  RdAnalysis  line 
segment’s nodes will be at either crossings with barangay boundaries  
or intersections with other roads:
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3.7 Zoom in to segment 1 to a scale about 1:15000 or use the scale selector and the 
pan tool. (Now it will be easier to digitize.)

3.8 Refer to the image below. Start (click once) at the barangay boundary and follow 
the road and click again after a small section. Continue to click once at points 
along the road. End at the crossing of the road leading south by double-clicking to 
finalize the road segment. The result is shown in the second image below:
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3.9 Assign another symbology to the RdAnalysis layer, so that your digital effort is 
clearly seen in the map. Choose for example a red and wide line symbol. 

If you are not pleased with the result, use the redo button before you 
proceed with the next segment. Also get into the habit of saving (2)  
your  work  often.  When  you  are  finished  or  need  to  proceed  with  
another  GIS operation you should stop editing (1).  Refer  to  image 
below.

3.10 Repeat step 3.8 on the other segments. Follow the order given in the sketch 
image just before step 3.7 above. When you’re done with this, your map should 
look something like this.
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3.10 Click Editor > Stop Editing.

4 Assigning Road Segment ID to Conform with Attributes in the dBase File
4.1 Don’t close the editor. Open the attribute table by right-clicking on RdAnalysis in 

the list of content and selecting Open Attribute Table. The Attributes of  
RdAnalysis window appears. See image below. If you have followed the sketch 
above you should have ten segments in the table, each with its unique FID 
number. There is also another Id column that has zeros at the moment but needs 
to be identified in order to connect it with the attributes in the Excel/dBase tables.

4.2 So what ID should we give the segments? Well, there could be different 
alternatives. Here, we need to use the IDs that are found in the dBase file. decide 
to use the PSDG number of the barangay where the road segment is situated to 
give it its unique ID number. To facilitate we insert a name label for the 
barangays. In the table of content, right-click on the barangay boundary layer and 
select Properties. 

4.3 The Layer Properties window appears (see image below). Go to the Labels tab. 
Select Label features in this layer. From the list menu to Label field select NAME. 
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Click OK.

The result will look something like the image below and you see that in 
this case the road passes the barangays of Niyugan, As-is, Poblacion 1 
and Poblacion 4.

The first segment is situated in a barangay named Niyugan, which has  
a barangay ID (0)1. We assume that we do not need to divide a road  
into more than 99 segments in a barangay. As this segment is the first  
we give it the unique ID of 101. 

4.4 Make sure that you are still in editing mode. (If not choose Editor > Start Editing 
from the editor toolbar.) Return to or open the attribute table (refer to step 4.1 if 
needed). 
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4.5 Place the cursor in the first row in the Id column in the Attributes of RdAnalysis 
table window. Click once and type 1401 for FID0. (Since As-is barangay ID is 14 
and this constitutes the first road segment in barangay.)

4.6 Providing that you digitized the same segments in the same order as in the sketch 
above, repeat step 4.5 on the other rows and assign Id according to the 
table/image below:.

4.7 Click Editor > Save Editing.
4.8 Also make sure to save the map document road_analysis_v1 by either clicking on 

 in the toolbar or selecting File > Save in the menu bar.
5 Converting the Attribute Excel File to dBase Format

We will now work on the dBase Table with additional attribute data of  
the road. (This data has been captured on ground within a field survey  
and entered into an excel file.) When working with Excel, it is always  
recommended that ArcMap is closed (and vice versa). This is due to  
avoid accessing the same files from the two programs, which can lead 
to quite some problems. If you have a printed sketch map with the  
segments, also add the new Id numbers onto this map.

5.1 Close ArcMap. Open Excel.
5.2 Open the file IS01_RdTp2007.xls found in C:\HLURB\CLUP\01_CLUPGIS 

(Laurel)\02_IS\. (See image below where, for example, the road segment with ID 
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101 is municipal road, has a gravel surface and is in a poor condition.

5.3 Select (highlight) the cells that will be found in the dBase file. (Place the cursor in 
cell B2 and drag it to cell H12.) From the excel menu bar, select Edit > Copy.

5.4 Open a new file. (Go to File > New then select New empty document.) Place the 
cursor in cell A1 and select Edit > Paste. See image below.
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5.5 The head column must be in one line in dBase format. Select the cells constituting 
the column head (A1:G1). From the menu bar select Format > Column > AutoFit 
Selection.

5.6 Only one sheet is allowed in dBase. Remove Sheet 2 by right-clicking on the 
Sheet2 tab and selecting Delete. (See image below.) Repeat this procedure on 
Sheet 3:

5.7 Select only the cells with data (A1:G9). Select File > Save as… 
5.8 In the Save As window, browse for the folder 

C:\HLURB\CLUP\01_CLUPGIS(Laurel)\02_IS\ and type the File name 
IS01_RdTp2007.dbf. From the Save as type menu list, select the DBF 4 (dBASE 
IV) (*dbf) option. Click Save.

5.9 Now a couple of alerts will appear one after each other. Simply click OK to the 
alert as below:
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5.10 Click Yes to the alert below:

5.11 Click the exit button (1) and Yes (2) below.

5.12 Click OK again

5.13 Finally, click Yes.
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5.14 Close Excel.
It’s always recommended to have Excel closed when you work with  
ArcGIS.

If you want to revise a .dbf file you should close ArcGIS before you  
open Excel.

6 Joining the dBase File to the Shapefile
6.1 Open ArcMap and the map document road_analysis_v1.
6.2 In the table of content, right-click on RdAnalysis and select Joins and Relates > 

Join… (see image below).

6.3 The Join Data window appears. (See image below.) You should have the 
following settings:
1.’ Id’ was the column head where you inserted the unique Ids for the road 
segments
2. ‘IS01_RdYr’ is the name of the dBase table you have prepared that contains 
the attribute information of the road segments.
3. RD_ID is the name of the column where the unique ID have been inserted
4. Click OK.
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7 Viewing the Result of the Analysis
7.1 Open the attribute table for the RdAnalysis layer. As you can see, the columns 

from the dBase table have been intergrated. 
7.2 To make the table easier to read we need to hide some columns and give proper 

alias. Open the Layer Properties window and go to the Fields tab.
7.3 Place the cursor on the first row (RDAnalysis.FID). This is ArcGIS’s column with 

little information value for us. Therefore, unselect the Visible box. (See image 
below.)
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7.4 Repeat step 7.3 for the consecutive fields. If a field is selected visible, you should 
assign a more understandable Alias.
Set the following fields to be visible and assign the respective alias:
IS01_Rd_ - ‘Road Segment ID’
ISO1_Rd_ - ‘Road Classification’
Etc…
You have completed the exercise! Well done.

You can now think of different ways to present the analysis. Test the 
“interactive presentation” by using the Identify tool on the Rd_analysis  
layer. Since you’ve set the fields display properties above and thus  
reduced redundant and unnecessary information, the result will be fairly  
easy to interpret for a “normal” computer user.  
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